Quick-Tip: Solving a problem with Letsencrypt and Python < 2.7

Tuesday, April 9, 2019 at 12:35 AM UTC

I just stumbled upon a problem on my older system as I tried to update my SSL certificate with Letsencrypt.

The certbot-auto script stopped working and gave me errors regarding the pip module.

As of version 0.32.0 Letsencrypt stopped supporting Python version older than 2.7. There is a solution though:

https://github.com/certbot/certbot/issues/6824#issuecomment-470525460

The line numbers didn't match in my case but just search for them (I found them about 40 lines further).

After changing those lines the script worked again with my older Python version.

Of course you should always try to update your system but sometimes you just can't. Hope this helps!





Latest comments to this post

Christoph Stoettner wrote on 09.04.2019, 04:22

Python 2.7 end of maintenance is 1.1.2020, maybe it's time to think about updating to 3.x!

https://pythonclock.org 

 Link to this comment

Leave a comment right here